zd小达
一只萌萌哒的初中生
[Linux]纯净vps如何建站?戳这儿看看(*'▽'*)♪

Linux——世界上为数不多的开源系统,它几乎遍布了我们的生活,而因为它的开源性,使得很多开发商都选择使用Linux vps来搭建网站,但。。。你想问了,Linux全是命令行,怎么建站呢?这就是我今天想说的内容。(废话开头)

Linux小企鹅

要想在Linux上建站,你必须得知道,Linux只是一个系统内核,而Linux的这些系统,例如:centos,Ubuntu还有Android,都是开发商基于Linux二次开发的,我们把它称为Linux的分支,这些分支也因为开发商的习惯,命令会各不相同,接下来我会在centos和Ubuntu的环境里讲述如何建站。(由于Aliyun Linux的特殊性,centos的命令它同样适用)

1.选购Linux

说到vps,首先想到的就是阿里云,腾讯云这些国内大厂了,其次这是一些国外的vps。就我个人来说,国内vps比较好,虽说要备案,但确实不麻烦,十几天,填填资料,拍几张照就好了。而国外vps虽说可以当做跨越万里长城的梯子,但意义不大,容易被封,且国内速度慢,价高。对新手来说,还是国内的好一点。

腾讯云
阿里云

这里就以国内来说明,在国内,我本人首推阿里云(非恰饭)。为什么>o<。

便宜!!!

阿里云的学生机是目前国内最便宜的vps了,一个月只要9.5,9.5嘞。不限次数,只限年龄。其他的某为,某讯还™限制次数,最多3次,有这么玩的吗?当然,景安的免费主机也是个不错的选择(不过不能折腾)。这里还要说一点,一定不要用那些所谓的免费vps,免费就是最大的付费,逼着你发布帖子做宣传,还不定时的删库跑路,可耻→_→

从删库到跑路

2.选择系统

虽说选择系统是个不起眼的小步骤,但我依然单独列成了一个大点,为什么?因为它真的很重要。这里推荐3款Linux系统选择。如果你是阿里云用户,aliyun linux一定是个不错的选择,毕竟有阿里云团队的优()化(),心理效果首先就是满分。接着就是centos和Ubuntu,注意了!这两个系统都不是国人开发,但却使用的不是同一个软件源,centos用的是yum源,Ubuntu则是apt源,如果说你是要租个vps开我的世界,一定一定一定要选Ubuntu,而且是最新版,因为我的世界官方服务端只支持Ubuntu。可只是单纯想建站,随便哪个都可以哦(´-ω-`)。

centos
Ubuntu乌班图

3.安装LNMP

LNMP是一款建站的配套软件,而早期因为复杂的英文代码导致入门门槛很高,需要一定的英文基础。可现在,有一个国人团队开发出了一个全中文无代码的服务器管理面板——宝塔面板。只需一两行easy的命令即可完成安装,很是简单。而且它还是开源的,完全不用担心后门问题。

宝塔面板

centos

yum install -y wget && wget -O install.sh http://download.bt.cn/install/install_6.0.sh && sh install.sh

Ubuntu

wget -O install.sh http://download.bt.cn/install/install-ubuntu_6.0.sh && sudo bash install.sh

一定要使用root权限运行(●°u°●)​ 」

root命令

sudo su root

输入密码即可

4.安装过程

为了防止部分小白迷路,这里我把安装日志也给复制了下来,这是在Ubuntu 16.04.3的机子上安装的,想看就看看吧!

安装日志,约一万字,谨慎打开
keyboard_arrow_down

  Welcome to Ubuntu 16.04.3 LTS (GNU/Linux 4.4.0-93-generic x86_64) * Documentation: https://help.ubuntu.com * Management: https://landscape.canonical.com * Support: https://ubuntu.com/advantage Welcome to Alibaba Cloud Elastic Compute Service ! root@iZ2ze24ocbpohl87u8q2pdZ:~# wget -O install.sh http://download.bt.cn/install/install-ubuntu_6.0.sh && sudo bash install.sh –2019-11-24 19:45:53– http://download.bt.cn/install/install-ubuntu_6.0.sh Resolving download.bt.cn (download.bt.cn)… 125.88.182.172, 240e:ff:9000:1100:0:3:0:35 Connecting to download.bt.cn (download.bt.cn)|125.88.182.172|:80… connected. HTTP request sent, awaiting response… 200 OK Length: 19776 (19K) [application/octet-stream] Saving to: ‘install.sh’ install.sh 100%[================>] 19.31K –.-KB/s in 0.05s 2019-11-24 19:45:54 (420 KB/s) – ‘install.sh’ saved [19776/19776] sudo: unable to resolve host iZ2ze24ocbpohl87u8q2pdZ +———————————————————————- | Bt-WebPanel 6.0 FOR CentOS/Ubuntu/Debian +———————————————————————- | Copyright © 2015-2099 BT-SOFT(http://www.bt.cn) All rights reserved. +———————————————————————- | The WebPanel URL will be http://SERVER_IP:8888 when installed. +———————————————————————- Do you want to install Bt-Panel to the /www directory now?(y/n): y ——————————————— Selected download node… Reading package lists… Done Building dependency tree Reading state information… Done curl is already the newest version (7.47.0-1ubuntu2.2). 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. curl: (28) Connection timed out after 3001 milliseconds install.sh: line 120: [: =: unary operator expected Download node: http://119.188.210.21:5880 ——————————————— Hit:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial InRelease Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates InRelease [109 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security InRelease [109 kB] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main Sources [343 kB] Get:5 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/universe Sources [263 kB] Get:6 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 Packages [1,070 kB] Get:7 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main i386 Packages [882 kB] Get:8 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main Translation-en [413 kB] Get:9 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/universe amd64 Packages [770 kB] Get:10 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/universe i386 Packages [699 kB] Get:11 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/universe Translation-en [323 kB] Get:12 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/main Sources [157 kB] Get:13 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/universe Sources [114 kB] Get:14 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/main amd64 Packages [784 kB] Get:15 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/main i386 Packages [616 kB] Get:16 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/main Translation-en [302 kB] Get:17 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/universe amd64 Packages [465 kB] Get:18 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/universe i386 Packages [400 kB] Get:19 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-security/universe Translation-en [191 kB] Fetched 8,009 kB in 2s (3,720 kB/s) Reading package lists… Done Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: fonts-lato javascript-common libjs-jquery libruby2.3 libyaml-0-2 rake ruby-did-you-mean ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby2.3 rubygems-integration unzip zip Suggested packages: apache2 | lighttpd | httpd ri ruby-dev bundler The following NEW packages will be installed: fonts-lato javascript-common libjs-jquery libruby2.3 libyaml-0-2 rake ruby ruby-did-you-mean ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby2.3 rubygems-integration unzip zip 0 upgraded, 16 newly installed, 0 to remove and 250 not upgraded. Need to get 6,411 kB of archives. After this operation, 28.8 MB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 fonts-lato all 2.0-1 [2,693 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libyaml-0-2 amd64 0.1.6-3 [47.6 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 javascript-common all 11 [6,066 B] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libjs-jquery all 1.11.3+dfsg-4 [161 kB] Get:5 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 rubygems-integration all 1.10 [4,966 B] Get:6 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 ruby-did-you-mean all 1.0.0-2 [8,390 B] Get:7 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 ruby-minitest all 5.8.4-2 [36.6 kB] Get:8 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 ruby-net-telnet all 0.1.1-2 [12.6 kB] Get:9 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 ruby-power-assert all 0.2.7-1 [7,668 B] Get:10 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 ruby-test-unit all 3.1.7-2 [60.3 kB] Get:11 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libruby2.3 amd64 2.3.1-2~ubuntu16.04.13 [2,961 kB] Get:12 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 ruby2.3 amd64 2.3.1-2~ubuntu16.04.13 [41.0 kB] Get:13 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 ruby all 1:2.3.0+1 [5,530 B] Get:14 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 rake all 10.5.0-2 [48.2 kB] Get:15 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 unzip amd64 6.0-20ubuntu1 [158 kB] Get:16 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 zip amd64 3.0-11 [158 kB] Fetched 6,411 kB in 0s (7,903 kB/s) Selecting previously unselected package fonts-lato. (Reading database … 100151 files and directories currently installed.) Preparing to unpack …/fonts-lato_2.0-1_all.deb … Unpacking fonts-lato (2.0-1) … Selecting previously unselected package libyaml-0-2:amd64. Preparing to unpack …/libyaml-0-2_0.1.6-3_amd64.deb … Unpacking libyaml-0-2:amd64 (0.1.6-3) … Selecting previously unselected package javascript-common. Preparing to unpack …/javascript-common_11_all.deb … Unpacking javascript-common (11) … Selecting previously unselected package libjs-jquery. Preparing to unpack …/libjs-jquery_1.11.3+dfsg-4_all.deb … Unpacking libjs-jquery (1.11.3+dfsg-4) … Selecting previously unselected package rubygems-integration. Preparing to unpack …/rubygems-integration_1.10_all.deb … Unpacking rubygems-integration (1.10) … Selecting previously unselected package ruby-did-you-mean. Preparing to unpack …/ruby-did-you-mean_1.0.0-2_all.deb … Unpacking ruby-did-you-mean (1.0.0-2) … Selecting previously unselected package ruby-minitest. Preparing to unpack …/ruby-minitest_5.8.4-2_all.deb … Unpacking ruby-minitest (5.8.4-2) … Selecting previously unselected package ruby-net-telnet. Preparing to unpack …/ruby-net-telnet_0.1.1-2_all.deb … Unpacking ruby-net-telnet (0.1.1-2) … Selecting previously unselected package ruby-power-assert. Preparing to unpack …/ruby-power-assert_0.2.7-1_all.deb … Unpacking ruby-power-assert (0.2.7-1) … Selecting previously unselected package ruby-test-unit. Preparing to unpack …/ruby-test-unit_3.1.7-2_all.deb … Unpacking ruby-test-unit (3.1.7-2) … Selecting previously unselected package libruby2.3:amd64. Preparing to unpack …/libruby2.3_2.3.1-2~ubuntu16.04.13_amd64.deb … Unpacking libruby2.3:amd64 (2.3.1-2~ubuntu16.04.13) … Selecting previously unselected package ruby2.3. Preparing to unpack …/ruby2.3_2.3.1-2~ubuntu16.04.13_amd64.deb … Unpacking ruby2.3 (2.3.1-2~ubuntu16.04.13) … Selecting previously unselected package ruby. Preparing to unpack …/ruby_1%3a2.3.0+1_all.deb … Unpacking ruby (1:2.3.0+1) … Selecting previously unselected package rake. Preparing to unpack …/archives/rake_10.5.0-2_all.deb … Unpacking rake (10.5.0-2) … Selecting previously unselected package unzip. Preparing to unpack …/unzip_6.0-20ubuntu1_amd64.deb … Unpacking unzip (6.0-20ubuntu1) … Selecting previously unselected package zip. Preparing to unpack …/archives/zip_3.0-11_amd64.deb … Unpacking zip (3.0-11) … Processing triggers for libc-bin (2.23-0ubuntu9) … Processing triggers for man-db (2.7.5-1) … Processing triggers for mime-support (3.59ubuntu1) … Setting up fonts-lato (2.0-1) … Setting up libyaml-0-2:amd64 (0.1.6-3) … Setting up javascript-common (11) … Setting up libjs-jquery (1.11.3+dfsg-4) … Setting up rubygems-integration (1.10) … Setting up ruby-did-you-mean (1.0.0-2) … Setting up ruby-minitest (5.8.4-2) … Setting up ruby-net-telnet (0.1.1-2) … Setting up ruby-power-assert (0.2.7-1) … Setting up ruby-test-unit (3.1.7-2) … Setting up unzip (6.0-20ubuntu1) … Setting up zip (3.0-11) … Setting up libruby2.3:amd64 (2.3.1-2~ubuntu16.04.13) … Setting up ruby2.3 (2.3.1-2~ubuntu16.04.13) … Setting up ruby (1:2.3.0+1) … Setting up rake (10.5.0-2) … Processing triggers for libc-bin (2.23-0ubuntu9) … Reading package lists… Done Building dependency tree Reading state information… Done lsb-release is already the newest version (9.20160110ubuntu0.2). 0 upgraded, 0 newly installed, 0 to remove and 250 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following packages will be upgraded: wget 1 upgraded, 0 newly installed, 0 to remove and 249 not upgraded. Need to get 299 kB of archives. After this operation, 4,096 B of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 wget amd64 1.17.1-1ubuntu1.5 [299 kB] Fetched 299 kB in 0s (3,642 kB/s) (Reading database … 101455 files and directories currently installed.) Preparing to unpack …/wget_1.17.1-1ubuntu1.5_amd64.deb … Unpacking wget (1.17.1-1ubuntu1.5) over (1.17.1-1ubuntu1.2) … Processing triggers for install-info (6.1.0.dfsg.1-5) … Processing triggers for man-db (2.7.5-1) … Setting up wget (1.17.1-1ubuntu1.5) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libcurl3-gnutls The following packages will be upgraded: curl libcurl3-gnutls 2 upgraded, 0 newly installed, 0 to remove and 247 not upgraded. Need to get 323 kB of archives. After this operation, 4,096 B of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 curl amd64 7.47.0-1ubuntu2.14 [139 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libcurl3-gnutls amd64 7.47.0-1ubuntu2.14 [184 kB] Fetched 323 kB in 0s (4,168 kB/s) (Reading database … 101455 files and directories currently installed.) Preparing to unpack …/curl_7.47.0-1ubuntu2.14_amd64.deb … Unpacking curl (7.47.0-1ubuntu2.14) over (7.47.0-1ubuntu2.2) … Preparing to unpack …/libcurl3-gnutls_7.47.0-1ubuntu2.14_amd64.deb … Unpacking libcurl3-gnutls:amd64 (7.47.0-1ubuntu2.14) over (7.47.0-1ubuntu2.2) … Processing triggers for man-db (2.7.5-1) … Processing triggers for libc-bin (2.23-0ubuntu9) … Setting up libcurl3-gnutls:amd64 (7.47.0-1ubuntu2.14) … Setting up curl (7.47.0-1ubuntu2.14) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libpython-all-dev libpython-dev libpython-stdlib python-all python-all-dev python-dev python-minimal Suggested packages: python-doc python-tk The following packages will be upgraded: libpython-all-dev libpython-dev libpython-stdlib python python-all python-all-dev python-dev python-minimal 8 upgraded, 0 newly installed, 0 to remove and 239 not upgraded. Need to get 185 kB of archives. After this operation, 0 B of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python-all-dev amd64 2.7.12-1~16.04 [1,016 B] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python-dev amd64 2.7.12-1~16.04 [1,186 B] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python-all amd64 2.7.12-1~16.04 [996 B] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python-minimal amd64 2.7.12-1~16.04 [28.1 kB] Get:5 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python amd64 2.7.12-1~16.04 [137 kB] Get:6 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython-all-dev amd64 2.7.12-1~16.04 [1,006 B] Get:7 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython-dev amd64 2.7.12-1~16.04 [7,840 B] Get:8 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython-stdlib amd64 2.7.12-1~16.04 [7,768 B] Fetched 185 kB in 0s (722 kB/s) (Reading database … 101455 files and directories currently installed.) Preparing to unpack …/python-all-dev_2.7.12-1~16.04_amd64.deb … Unpacking python-all-dev (2.7.12-1~16.04) over (2.7.11-1) … Preparing to unpack …/python-dev_2.7.12-1~16.04_amd64.deb … Unpacking python-dev (2.7.12-1~16.04) over (2.7.11-1) … Preparing to unpack …/python-all_2.7.12-1~16.04_amd64.deb … Unpacking python-all (2.7.12-1~16.04) over (2.7.11-1) … Preparing to unpack …/python-minimal_2.7.12-1~16.04_amd64.deb … Unpacking python-minimal (2.7.12-1~16.04) over (2.7.11-1) … Processing triggers for man-db (2.7.5-1) … Setting up python-minimal (2.7.12-1~16.04) … (Reading database … 101455 files and directories currently installed.) Preparing to unpack …/python_2.7.12-1~16.04_amd64.deb … Unpacking python (2.7.12-1~16.04) over (2.7.11-1) … Preparing to unpack …/libpython-all-dev_2.7.12-1~16.04_amd64.deb … Unpacking libpython-all-dev:amd64 (2.7.12-1~16.04) over (2.7.11-1) … Preparing to unpack …/libpython-dev_2.7.12-1~16.04_amd64.deb … Unpacking libpython-dev:amd64 (2.7.12-1~16.04) over (2.7.11-1) … Preparing to unpack …/libpython-stdlib_2.7.12-1~16.04_amd64.deb … Unpacking libpython-stdlib:amd64 (2.7.12-1~16.04) over (2.7.11-1) … Processing triggers for man-db (2.7.5-1) … Setting up libpython-stdlib:amd64 (2.7.12-1~16.04) … Setting up python (2.7.12-1~16.04) … Setting up python-all (2.7.12-1~16.04) … Setting up libpython-dev:amd64 (2.7.12-1~16.04) … Setting up libpython-all-dev:amd64 (2.7.12-1~16.04) … Setting up python-dev (2.7.12-1~16.04) … Setting up python-all-dev (2.7.12-1~16.04) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done python-dev is already the newest version (2.7.12-1~16.04). python-dev set to manually installed. 0 upgraded, 0 newly installed, 0 to remove and 239 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: liblcms2-2 libwebp5 libwebpmux1 python-pil Suggested packages: liblcms2-utils python-pil-doc python-pil-dbg The following NEW packages will be installed: liblcms2-2 libwebp5 libwebpmux1 python-imaging python-pil 0 upgraded, 5 newly installed, 0 to remove and 239 not upgraded. Need to get 633 kB of archives. After this operation, 2,262 kB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 liblcms2-2 amd64 2.6-3ubuntu2.1 [136 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libwebp5 amd64 0.4.4-1 [165 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libwebpmux1 amd64 0.4.4-1 [14.2 kB] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python-pil amd64 3.1.2-0ubuntu1.1 [312 kB] Get:5 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/universe amd64 python-imaging all 3.1.2-0ubuntu1.1 [4,596 B] Fetched 633 kB in 0s (2,542 kB/s) Selecting previously unselected package liblcms2-2:amd64. (Reading database … 101455 files and directories currently installed.) Preparing to unpack …/liblcms2-2_2.6-3ubuntu2.1_amd64.deb … Unpacking liblcms2-2:amd64 (2.6-3ubuntu2.1) … Selecting previously unselected package libwebp5:amd64. Preparing to unpack …/libwebp5_0.4.4-1_amd64.deb … Unpacking libwebp5:amd64 (0.4.4-1) … Selecting previously unselected package libwebpmux1:amd64. Preparing to unpack …/libwebpmux1_0.4.4-1_amd64.deb … Unpacking libwebpmux1:amd64 (0.4.4-1) … Selecting previously unselected package python-pil:amd64. Preparing to unpack …/python-pil_3.1.2-0ubuntu1.1_amd64.deb … Unpacking python-pil:amd64 (3.1.2-0ubuntu1.1) … Selecting previously unselected package python-imaging. Preparing to unpack …/python-imaging_3.1.2-0ubuntu1.1_all.deb … Unpacking python-imaging (3.1.2-0ubuntu1.1) … Processing triggers for libc-bin (2.23-0ubuntu9) … Setting up liblcms2-2:amd64 (2.6-3ubuntu2.1) … Setting up libwebp5:amd64 (0.4.4-1) … Setting up libwebpmux1:amd64 (0.4.4-1) … Setting up python-pil:amd64 (3.1.2-0ubuntu1.1) … Setting up python-imaging (3.1.2-0ubuntu1.1) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done zip is already the newest version (3.0-11). zip set to manually installed. 0 upgraded, 0 newly installed, 0 to remove and 239 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done unzip is already the newest version (6.0-20ubuntu1). unzip set to manually installed. 0 upgraded, 0 newly installed, 0 to remove and 239 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following packages will be upgraded: openssl 1 upgraded, 0 newly installed, 0 to remove and 238 not upgraded. Need to get 492 kB of archives. After this operation, 0 B of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 openssl amd64 1.0.2g-1ubuntu4.15 [492 kB] Fetched 492 kB in 0s (3,973 kB/s) (Reading database … 101616 files and directories currently installed.) Preparing to unpack …/openssl_1.0.2g-1ubuntu4.15_amd64.deb … Unpacking openssl (1.0.2g-1ubuntu4.15) over (1.0.2g-1ubuntu4.8) … Processing triggers for man-db (2.7.5-1) … Setting up openssl (1.0.2g-1ubuntu4.15) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libssl-doc libssl1.0.0 zlib1g-dev The following NEW packages will be installed: libssl-dev libssl-doc zlib1g-dev The following packages will be upgraded: libssl1.0.0 1 upgraded, 3 newly installed, 0 to remove and 237 not upgraded. Need to get 3,673 kB of archives. After this operation, 10.5 MB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libssl1.0.0 amd64 1.0.2g-1ubuntu4.15 [1,084 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 zlib1g-dev amd64 1:1.2.8.dfsg-2ubuntu4.1 [168 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libssl-dev amd64 1.0.2g-1ubuntu4.15 [1,344 kB] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libssl-doc all 1.0.2g-1ubuntu4.15 [1,077 kB] Fetched 3,673 kB in 0s (12.6 MB/s) Preconfiguring packages … (Reading database … 101616 files and directories currently installed.) Preparing to unpack …/libssl1.0.0_1.0.2g-1ubuntu4.15_amd64.deb … Unpacking libssl1.0.0:amd64 (1.0.2g-1ubuntu4.15) over (1.0.2g-1ubuntu4.8) …Selecting previously unselected package zlib1g-dev:amd64. Preparing to unpack …/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4.1_amd64.deb … Unpacking zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu4.1) … Selecting previously unselected package libssl-dev:amd64. Preparing to unpack …/libssl-dev_1.0.2g-1ubuntu4.15_amd64.deb … Unpacking libssl-dev:amd64 (1.0.2g-1ubuntu4.15) … Selecting previously unselected package libssl-doc. Preparing to unpack …/libssl-doc_1.0.2g-1ubuntu4.15_all.deb … Unpacking libssl-doc (1.0.2g-1ubuntu4.15) … Processing triggers for libc-bin (2.23-0ubuntu9) … Processing triggers for man-db (2.7.5-1) … Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu4.15) … Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2ubuntu4.1) … Setting up libssl-dev:amd64 (1.0.2g-1ubuntu4.15) … Setting up libssl-doc (1.0.2g-1ubuntu4.15) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done gcc is already the newest version (4:5.3.1-1ubuntu1). 0 upgraded, 0 newly installed, 0 to remove and 237 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following packages will be upgraded: libxml2 1 upgraded, 0 newly installed, 0 to remove and 236 not upgraded. Need to get 697 kB of archives. After this operation, 0 B of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libxml2 amd64 2.9.3+dfsg1-1ubuntu0.6 [697 kB] Fetched 697 kB in 0s (10.4 MB/s) (Reading database … 103406 files and directories currently installed.) Preparing to unpack …/libxml2_2.9.3+dfsg1-1ubuntu0.6_amd64.deb … Unpacking libxml2:amd64 (2.9.3+dfsg1-1ubuntu0.6) over (2.9.3+dfsg1-1ubuntu0.2) … Processing triggers for libc-bin (2.23-0ubuntu9) … Setting up libxml2:amd64 (2.9.3+dfsg1-1ubuntu0.6) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: icu-devtools libicu-dev libicu55 Suggested packages: icu-doc pkg-config The following NEW packages will be installed: icu-devtools libicu-dev libxml2-dev The following packages will be upgraded: libicu55 1 upgraded, 3 newly installed, 0 to remove and 235 not upgraded. Need to get 17.1 MB of archives. After this operation, 45.0 MB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libicu55 amd64 55.1-7ubuntu0.4 [7,646 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 icu-devtools amd64 55.1-7ubuntu0.4 [166 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libicu-dev amd64 55.1-7ubuntu0.4 [8,566 kB] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libxml2-dev amd64 2.9.3+dfsg1-1ubuntu0.6 [743 kB] Fetched 17.1 MB in 0s (38.9 MB/s) (Reading database … 103406 files and directories currently installed.) Preparing to unpack …/libicu55_55.1-7ubuntu0.4_amd64.deb … Unpacking libicu55:amd64 (55.1-7ubuntu0.4) over (55.1-7ubuntu0.2) … Selecting previously unselected package icu-devtools. Preparing to unpack …/icu-devtools_55.1-7ubuntu0.4_amd64.deb … Unpacking icu-devtools (55.1-7ubuntu0.4) … Selecting previously unselected package libicu-dev:amd64. Preparing to unpack …/libicu-dev_55.1-7ubuntu0.4_amd64.deb … Unpacking libicu-dev:amd64 (55.1-7ubuntu0.4) … Selecting previously unselected package libxml2-dev:amd64. Preparing to unpack …/libxml2-dev_2.9.3+dfsg1-1ubuntu0.6_amd64.deb … Unpacking libxml2-dev:amd64 (2.9.3+dfsg1-1ubuntu0.6) … Processing triggers for libc-bin (2.23-0ubuntu9) … Processing triggers for man-db (2.7.5-1) … Setting up libicu55:amd64 (55.1-7ubuntu0.4) … Setting up icu-devtools (55.1-7ubuntu0.4) … Setting up libicu-dev:amd64 (55.1-7ubuntu0.4) … Setting up libxml2-dev:amd64 (2.9.3+dfsg1-1ubuntu0.6) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done E: Unable to locate package libxslt Reading package lists… Done Building dependency tree Reading state information… Done zlib1g is already the newest version (1:1.2.8.dfsg-2ubuntu4.1). 0 upgraded, 0 newly installed, 0 to remove and 235 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done zlib1g-dev is already the newest version (1:1.2.8.dfsg-2ubuntu4.1). zlib1g-dev set to manually installed. 0 upgraded, 0 newly installed, 0 to remove and 235 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libjpeg-turbo8 libjpeg-turbo8-dev libjpeg8-dev The following NEW packages will be installed: libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev The following packages will be upgraded: libjpeg-turbo8 1 upgraded, 3 newly installed, 0 to remove and 234 not upgraded. Need to get 368 kB of archives. After this operation, 1,471 kB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libjpeg-turbo8 amd64 1.4.2-0ubuntu3.3 [111 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libjpeg-turbo8-dev amd64 1.4.2-0ubuntu3.3 [255 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libjpeg8-dev amd64 8c-2ubuntu8 [1,552 B] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libjpeg-dev amd64 8c-2ubuntu8 [1,546 B] Fetched 368 kB in 0s (2,251 kB/s) (Reading database … 104014 files and directories currently installed.) Preparing to unpack …/libjpeg-turbo8_1.4.2-0ubuntu3.3_amd64.deb … Unpacking libjpeg-turbo8:amd64 (1.4.2-0ubuntu3.3) over (1.4.2-0ubuntu3) … Selecting previously unselected package libjpeg-turbo8-dev:amd64. Preparing to unpack …/libjpeg-turbo8-dev_1.4.2-0ubuntu3.3_amd64.deb … Unpacking libjpeg-turbo8-dev:amd64 (1.4.2-0ubuntu3.3) … Selecting previously unselected package libjpeg8-dev:amd64. Preparing to unpack …/libjpeg8-dev_8c-2ubuntu8_amd64.deb … Unpacking libjpeg8-dev:amd64 (8c-2ubuntu8) … Selecting previously unselected package libjpeg-dev:amd64. Preparing to unpack …/libjpeg-dev_8c-2ubuntu8_amd64.deb … Unpacking libjpeg-dev:amd64 (8c-2ubuntu8) … Processing triggers for libc-bin (2.23-0ubuntu9) … Setting up libjpeg-turbo8:amd64 (1.4.2-0ubuntu3.3) … Setting up libjpeg-turbo8-dev:amd64 (1.4.2-0ubuntu3.3) … Setting up libjpeg8-dev:amd64 (8c-2ubuntu8) … Setting up libjpeg-dev:amd64 (8c-2ubuntu8) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done Note, selecting ‘libpng12-dev’ instead of ‘libpng-dev’ The following additional packages will be installed: libpng12-0 The following NEW packages will be installed: libpng12-dev The following packages will be upgraded: libpng12-0 1 upgraded, 1 newly installed, 0 to remove and 233 not upgraded. Need to get 300 kB of archives. After this operation, 621 kB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpng12-0 amd64 1.2.54-1ubuntu1.1 [116 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpng12-dev amd64 1.2.54-1ubuntu1.1 [183 kB] Fetched 300 kB in 0s (2,578 kB/s) (Reading database … 104037 files and directories currently installed.) Preparing to unpack …/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb … Unpacking libpng12-0:amd64 (1.2.54-1ubuntu1.1) over (1.2.54-1ubuntu1) … Selecting previously unselected package libpng12-dev:amd64. Preparing to unpack …/libpng12-dev_1.2.54-1ubuntu1.1_amd64.deb … Unpacking libpng12-dev:amd64 (1.2.54-1ubuntu1.1) … Processing triggers for libc-bin (2.23-0ubuntu9) … Processing triggers for man-db (2.7.5-1) … Setting up libpng12-0:amd64 (1.2.54-1ubuntu1.1) … Setting up libpng12-dev:amd64 (1.2.54-1ubuntu1.1) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done lsof is already the newest version (4.89+dfsg-0.1). 0 upgraded, 0 newly installed, 0 to remove and 233 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done libpcre3 is already the newest version (2:8.38-3.1). 0 upgraded, 0 newly installed, 0 to remove and 233 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libpcre16-3 libpcre32-3 libpcrecpp0v5 The following NEW packages will be installed: libpcre16-3 libpcre3-dev libpcre32-3 libpcrecpp0v5 0 upgraded, 4 newly installed, 0 to remove and 233 not upgraded. Need to get 820 kB of archives. After this operation, 3,519 kB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libpcrecpp0v5 amd64 2:8.38-3.1 [15.2 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libpcre16-3 amd64 2:8.38-3.1 [144 kB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libpcre32-3 amd64 2:8.38-3.1 [136 kB] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libpcre3-dev amd64 2:8.38-3.1 [525 kB] Fetched 820 kB in 0s (4,092 kB/s) Selecting previously unselected package libpcrecpp0v5:amd64. (Reading database … 104062 files and directories currently installed.) Preparing to unpack …/libpcrecpp0v5_2%3a8.38-3.1_amd64.deb … Unpacking libpcrecpp0v5:amd64 (2:8.38-3.1) … Selecting previously unselected package libpcre16-3:amd64. Preparing to unpack …/libpcre16-3_2%3a8.38-3.1_amd64.deb … Unpacking libpcre16-3:amd64 (2:8.38-3.1) … Selecting previously unselected package libpcre32-3:amd64. Preparing to unpack …/libpcre32-3_2%3a8.38-3.1_amd64.deb … Unpacking libpcre32-3:amd64 (2:8.38-3.1) … Selecting previously unselected package libpcre3-dev:amd64. Preparing to unpack …/libpcre3-dev_2%3a8.38-3.1_amd64.deb … Unpacking libpcre3-dev:amd64 (2:8.38-3.1) … Processing triggers for libc-bin (2.23-0ubuntu9) … Processing triggers for man-db (2.7.5-1) … Setting up libpcrecpp0v5:amd64 (2:8.38-3.1) … Setting up libpcre16-3:amd64 (2:8.38-3.1) … Setting up libpcre32-3:amd64 (2:8.38-3.1) … Setting up libpcre3-dev:amd64 (2:8.38-3.1) … Processing triggers for libc-bin (2.23-0ubuntu9) … W: –force-yes is deprecated, use one of the options starting with –allow instead. Reading package lists… Done Building dependency tree Reading state information… Done cron is already the newest version (3.0pl1-128ubuntu2). 0 upgraded, 0 newly installed, 0 to remove and 233 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done python-dev is already the newest version (2.7.12-1~16.04). 0 upgraded, 0 newly installed, 0 to remove and 233 not upgraded. Reading package lists… Done Building dependency tree Reading state information… Done The following additional packages will be installed: libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib python2.7 python2.7-minimal Suggested packages: python2.7-doc binfmt-support The following packages will be upgraded: libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib python2.7 python2.7-dev python2.7-minimal 7 upgraded, 0 newly installed, 0 to remove and 226 not upgraded. Need to get 32.9 MB of archives. After this operation, 63.5 kB disk space will be freed. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python2.7-dev amd64 2.7.12-1ubuntu0~16.04.9 [276 kB] Get:2 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython2.7-dev amd64 2.7.12-1ubuntu0~16.04.9 [27.8 MB] Get:3 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython2.7 amd64 2.7.12-1ubuntu0~16.04.9 [1,070 kB] Get:4 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python2.7 amd64 2.7.12-1ubuntu0~16.04.9 [224 kB] Get:5 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython2.7-stdlib amd64 2.7.12-1ubuntu0~16.04.9 [1,884 kB] Get:6 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 python2.7-minimal amd64 2.7.12-1ubuntu0~16.04.9 [1,262 kB] Get:7 http://mirrors.cloud.aliyuncs.com/ubuntu xenial-updates/main amd64 libpython2.7-minimal amd64 2.7.12-1ubuntu0~16.04.9 [338 kB] Fetched 32.9 MB in 0s (36.5 MB/s) (Reading database … 104207 files and directories currently installed.) Preparing to unpack …/python2.7-dev_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking python2.7-dev (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Preparing to unpack …/libpython2.7-dev_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking libpython2.7-dev:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Preparing to unpack …/libpython2.7_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Preparing to unpack …/python2.7_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking python2.7 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Preparing to unpack …/libpython2.7-stdlib_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking libpython2.7-stdlib:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Preparing to unpack …/python2.7-minimal_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking python2.7-minimal (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Preparing to unpack …/libpython2.7-minimal_2.7.12-1ubuntu0~16.04.9_amd64.deb … Unpacking libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.9) over (2.7.12-1ubuntu0~16.04.1) … Processing triggers for man-db (2.7.5-1) … Processing triggers for libc-bin (2.23-0ubuntu9) … Processing triggers for mime-support (3.59ubuntu1) … Setting up libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.9) … Setting up python2.7-minimal (2.7.12-1ubuntu0~16.04.9) … Setting up libpython2.7-stdlib:amd64 (2.7.12-1ubuntu0~16.04.9) … Setting up python2.7 (2.7.12-1ubuntu0~16.04.9) … Setting up libpython2.7:amd64 (2.7.12-1ubuntu0~16.04.9) … Setting up libpython2.7-dev:amd64 (2.7.12-1ubuntu0~16.04.9) … Setting up python2.7-dev (2.7.12-1ubuntu0~16.04.9) … Processing triggers for libc-bin (2.23-0ubuntu9) … –2019-11-24 19:47:05– http://119.188.210.21:5880/install/src/panel6.zip Connecting to 119.188.210.21:5880… connected. HTTP request sent, awaiting response… 200 OK Length: 4557424 (4.3M) [application/zip] Saving to: ‘panel.zip’ panel.zip 100%[================>] 4.35M –.-KB/s in 0.1s 2019-11-24 19:47:05 (31.0 MB/s) – ‘panel.zip’ saved [4557424/4557424] –2019-11-24 19:47:05– http://119.188.210.21:5880/install/src/bt6.init Connecting to 119.188.210.21:5880… connected. HTTP request sent, awaiting response… 200 OK Length: 9109 (8.9K) [application/octet-stream] Saving to: ‘/etc/init.d/bt’ /etc/init.d/bt 100%[================>] 8.90K –.-KB/s in 0s 2019-11-24 19:47:05 (28.0 MB/s) – ‘/etc/init.d/bt’ saved [9109/9109] –2019-11-24 19:47:05– http://download.bt.cn/install/public.sh Resolving download.bt.cn (download.bt.cn)… 125.88.182.172, 240e:ff:9000:1100:0:3:0:35 Connecting to download.bt.cn (download.bt.cn)|125.88.182.172|:80… connected. HTTP request sent, awaiting response… 200 OK Length: 3640 (3.6K) [application/octet-stream] Saving to: ‘/www/server/panel/install/public.sh’ /www/server/panel/i 100%[================>] 3.55K –.-KB/s in 0.001s 2019-11-24 19:47:05 (5.50 MB/s) – ‘/www/server/panel/install/public.sh’ saved [3640/3640] bash: line 46: [: !=: unary operator expected https://pypi.tuna.tsinghua.edu.cn/simple Reading package lists… Done Building dependency tree Reading state information… Done The following NEW packages will be installed: libffi-dev 0 upgraded, 1 newly installed, 0 to remove and 226 not upgraded. Need to get 161 kB of archives. After this operation, 365 kB of additional disk space will be used. Get:1 http://mirrors.cloud.aliyuncs.com/ubuntu xenial/main amd64 libffi-dev amd64 3.2.1-4 [161 kB] Fetched 161 kB in 0s (1,792 kB/s) Selecting previously unselected package libffi-dev:amd64. (Reading database … 104207 files and directories currently installed.) Preparing to unpack …/libffi-dev_3.2.1-4_amd64.deb … Unpacking libffi-dev:amd64 (3.2.1-4) … Processing triggers for install-info (6.1.0.dfsg.1-5) … Processing triggers for man-db (2.7.5-1) … Setting up libffi-dev:amd64 (3.2.1-4) … Collecting setuptools Downloading https://pypi.tuna.tsinghua.edu.cn/packages/d9/de/554b6310ac87c5b921bc45634b07b11394fe63bc4cb5176f5240addf18ab/setuptools-41.6.0-py2.py3-none-any.whl (582kB) 100% |████████████████████████████████| 583kB 61.3MB/s Installing collected packages: setuptools Found existing installation: setuptools 20.7.0 Uninstalling setuptools-20.7.0: Successfully uninstalled setuptools-20.7.0 Successfully installed setuptools-41.6.0 ^NCollecting gunicorn==19.0 Downloading https://pypi.tuna.tsinghua.edu.cn/packages/ce/f0/70b402ce4a1988616a38524554ae6896846c4bad9c4e3e2dd43ead7c0d82/gunicorn-19.0.0.tar.gz (382kB) 100% |████████████████████████████████| 389kB 55.8MB/s Building wheels for collected packages: gunicorn Running setup.py bdist_wheel for gunicorn … done Stored in directory: /root/.cache/pip/wheels/7a/57/ae/4de78342be02719d878dc776e256502db002b106304a44b9ff Successfully built gunicorn Installing collected packages: gunicorn Successfully installed gunicorn-19.0.0 Collecting Flask>=1.0.2 (from -r /www/server/panel/requirements.txt (line 1)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/9b/93/628509b8d5dc749656a9641f4caf13540e2cdec85276964ff8f43bbb1d3b/Flask-1.1.1-py2.py3-none-any.whl (94kB) 100% |████████████████████████████████| 102kB 19.9MB/s Collecting paramiko>=2.6.0 (from -r /www/server/panel/requirements.txt (line 2)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/4b/80/74dace9e48b0ef923633dfb5e48798f58a168e4734bca8ecfaf839ba051a/paramiko-2.6.0-py2.py3-none-any.whl (199kB) 100% |████████████████████████████████| 204kB 49.5MB/s Collecting flask-socketio>=4.1.0 (from -r /www/server/panel/requirements.txt (line 3)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/66/44/edc4715af85671b943c18ac8345d0207972284a0cd630126ff5251faa08b/Flask_SocketIO-4.2.1-py2.py3-none-any.whl Collecting python-socketio>=4.2.0 (from -r /www/server/panel/requirements.txt (line 4)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/35/b0/22c3f785f23fec5c7a815f47c55d7e7946a67ae2129ff604148e939d3bdb/python_socketio-4.3.1-py2.py3-none-any.whl (49kB) 100% |████████████████████████████████| 51kB 54.8MB/s Collecting Werkzeug>=0.15.1 (from -r /www/server/panel/requirements.txt (line 5)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/ce/42/3aeda98f96e85fd26180534d36570e4d18108d62ae36f87694b476b83d6f/Werkzeug-0.16.0-py2.py3-none-any.whl (327kB) 100% |████████████████████████████████| 327kB 52.9MB/s Collecting Pillow==5.4.1 (from -r /www/server/panel/requirements.txt (line 6)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/0d/f3/421598450cb9503f4565d936860763b5af413a61009d87a5ab1e34139672/Pillow-5.4.1-cp27-cp27mu-manylinux1_x86_64.whl (2.0MB) 100% |████████████████████████████████| 2.0MB 78.2MB/s Collecting requests>=2.20 (from -r /www/server/panel/requirements.txt (line 7)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/51/bd/23c926cd341ea6b7dd0b2a00aba99ae0f828be89d72b2190f27c11d4b7fb/requests-2.22.0-py2.py3-none-any.whl (57kB) 100% |████████████████████████████████| 61kB 45.5MB/s Collecting cffi>=1.12.3 (from -r /www/server/panel/requirements.txt (line 8)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/93/5d/c4f950891251e478929036ca07b22f0b10324460c1d0a4434c584481db51/cffi-1.13.2-cp27-cp27mu-manylinux1_x86_64.whl (384kB) 100% |████████████████████████████████| 389kB 53.7MB/s Collecting psutil>=5.2.0 (from -r /www/server/panel/requirements.txt (line 9)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/03/9a/95c4b3d0424426e5fd94b5302ff74cea44d5d4f53466e1228ac8e73e14b4/psutil-5.6.5.tar.gz (447kB) 100% |████████████████████████████████| 450kB 49.4MB/s Requirement already satisfied: chardet>=3.0.4 in /usr/local/lib/python2.7/dist-packages (from -r /www/server/panel/requirements.txt (line 10)) Collecting Flask-Session>=0.3.1 (from -r /www/server/panel/requirements.txt (line 11)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/7e/a3/3ba4cec2becb7c4e65dfa95052c7050832c12a1fc8a475ac572842c460bc/Flask_Session-0.3.1-py2.py3-none-any.whl Collecting flask-sqlalchemy>=2.3.2 (from -r /www/server/panel/requirements.txt (line 12)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/1e/65/226d95466c75e34e291a76890ed0e27af2e46ab913002847856f11d4d59d/Flask_SQLAlchemy-2.4.1-py2.py3-none-any.whl Requirement already satisfied: gunicorn>=18.0 in /usr/local/lib/python2.7/dist-packages (from -r /www/server/panel/requirements.txt (line 13)) Collecting gevent-websocket>=0.10.1 (from -r /www/server/panel/requirements.txt (line 14)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/98/d2/6fa19239ff1ab072af40ebf339acd91fb97f34617c2ee625b8e34bf42393/gevent-websocket-0.10.1.tar.gzCollecting pyopenssl>=19.0 (from -r /www/server/panel/requirements.txt (line 15)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/9e/de/f8342b68fa9e981d348039954657bdf681b2ab93de27443be51865ffa310/pyOpenSSL-19.1.0-py2.py3-none-any.whl (53kB) 100% |████████████████████████████████| 61kB 48.7MB/s Collecting cryptography>=2.7 (from -r /www/server/panel/requirements.txt (line 16)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/e2/67/4597fc5d5de01bb44887844647ab8e73239079dd478c35c52d58a9eb3d45/cryptography-2.8-cp27-cp27mu-manylinux1_x86_64.whl (2.3MB) 100% |████████████████████████████████| 2.3MB 64.0MB/s Collecting six>=1.12.0 (from -r /www/server/panel/requirements.txt (line 17)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/65/26/32b8464df2a97e6dd1b656ed26b2c194606c16fe163c695a992b36c11cdf/six-1.13.0-py2.py3-none-any.whl Collecting itsdangerous>=0.24 (from Flask>=1.0.2->-r /www/server/panel/requirements.txt (line 1)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/76/ae/44b03b253d6fade317f32c24d100b3b35c2239807046a4c953c7b89fa49e/itsdangerous-1.1.0-py2.py3-none-any.whl Collecting Jinja2>=2.10.1 (from Flask>=1.0.2->-r /www/server/panel/requirements.txt (line 1)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/65/e0/eb35e762802015cab1ccee04e8a277b03f1d8e53da3ec3106882ec42558b/Jinja2-2.10.3-py2.py3-none-any.whl (125kB) 100% |████████████████████████████████| 133kB 60.9MB/s Collecting click>=5.1 (from Flask>=1.0.2->-r /www/server/panel/requirements.txt (line 1)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/fa/37/45185cb5abbc30d7257104c434fe0b07e5a195a6847506c074527aa599ec/Click-7.0-py2.py3-none-any.whl (81kB) 100% |████████████████████████████████| 81kB 47.2MB/s Collecting bcrypt>=3.1.3 (from paramiko>=2.6.0->-r /www/server/panel/requirements.txt (line 2)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/ad/36/9a0227d048e98409f012570f7bef8a8c2373b9c9c5dfbf82963cbae05ede/bcrypt-3.1.7-cp27-cp27mu-manylinux1_x86_64.whl (59kB) 100% |████████████████████████████████| 61kB 44.7MB/s Collecting pynacl>=1.0.1 (from paramiko>=2.6.0->-r /www/server/panel/requirements.txt (line 2)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/b3/25/e605574f24948a8a53b497744e93f061eb1dbe7c44b6465fc1c172d591aa/PyNaCl-1.3.0-cp27-cp27mu-manylinux1_x86_64.whl (762kB) 100% |████████████████████████████████| 768kB 64.3MB/s Collecting python-engineio>=3.9.0 (from python-socketio>=4.2.0->-r /www/server/panel/requirements.txt (line 4)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/9b/fb/843f043988306d12f27ae62a82ce26edc7513580e5e089b4911326879f7e/python_engineio-3.10.0-py2.py3-none-any.whl (120kB) 100% |████████████████████████████████| 122kB 56.3MB/s Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python2.7/dist-packages (from requests>=2.20->-r /www/server/panel/requirements.txt (line 7)) Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests>=2.20->-r /www/server/panel/requirements.txt (line 7)) Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python2.7/dist-packages (from requests>=2.20->-r /www/server/panel/requirements.txt (line 7)) Collecting pycparser (from cffi>=1.12.3->-r /www/server/panel/requirements.txt (line 8)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/68/9e/49196946aee219aead1290e00d1e7fdeab8567783e83e1b9ab5585e6206a/pycparser-2.19.tar.gz (158kB) 100% |████████████████████████████████| 163kB 67.6MB/s Collecting SQLAlchemy>=0.8.0 (from flask-sqlalchemy>=2.3.2->-r /www/server/panel/requirements.txt (line 12)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/34/5c/0e1d7ad0ca52544bb12f9cb8d5cc454af45821c92160ffedd38db0a317f6/SQLAlchemy-1.3.11.tar.gz (6.0MB) 100% |████████████████████████████████| 6.0MB 50.7MB/s Collecting gevent (from gevent-websocket>=0.10.1->-r /www/server/panel/requirements.txt (line 14)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/e6/e9/3a693414f706e12abe60554cd73c5ae8f848b182ae58018f93d86c9eb418/gevent-1.4.0-cp27-cp27mu-manylinux1_x86_64.whl (5.0MB) 100% |████████████████████████████████| 5.0MB 62.6MB/s Collecting enum34; python_version < “3” (from cryptography>=2.7->-r /www/server/panel/requirements.txt (line 16)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/c5/db/e56e6b4bbac7c4a06de1c50de6fe1ef3810018ae11732a50f15f62c7d050/enum34-1.1.6-py2-none-any.whl Collecting ipaddress; python_version < “3” (from cryptography>=2.7->-r /www/server/panel/requirements.txt (line 16)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/c2/f8/49697181b1651d8347d24c095ce46c7346c37335ddc7d255833e7cde674d/ipaddress-1.0.23-py2.py3-none-any.whl Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python2.7/dist-packages (from Jinja2>=2.10.1->Flask>=1.0.2->-r /www/server/panel/requirements.txt (line 1)) Collecting greenlet>=0.4.14; platform_python_implementation == “CPython” (from gevent->gevent-websocket>=0.10.1->-r /www/server/panel/requirements.txt (line 14)) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/8b/6e/f2d25875713ad0885c8d3c69269697406652e6f64e1a6bd8264f7a609327/greenlet-0.4.15-cp27-cp27mu-manylinux1_x86_64.whl Building wheels for collected packages: psutil, gevent-websocket, pycparser, SQLAlchemy Running setup.py bdist_wheel for psutil … done Stored in directory: /root/.cache/pip/wheels/42/94/f4/1b53c480ff4b378c71040e6ffc2095ae135095ab310caf8e2a Running setup.py bdist_wheel for gevent-websocket … done Stored in directory: /root/.cache/pip/wheels/51/da/7d/c432b1ee63098a1920d9d6a0ee9cb021557b485002ae39b663 Running setup.py bdist_wheel for pycparser … done Stored in directory: /root/.cache/pip/wheels/29/7e/f9/01296a948c211daf4da2672bd60c9f0606e20bb3c6fb28f211 Running setup.py bdist_wheel for SQLAlchemy … done Stored in directory: /root/.cache/pip/wheels/29/9f/8e/2ee27930d238be127119e8e067b5d628f64daed8d4610df835 Successfully built psutil gevent-websocket pycparser SQLAlchemy Installing collected packages: itsdangerous, Jinja2, click, Werkzeug, Flask, six, pycparser, cffi, bcrypt, pynacl, enum34, ipaddress, cryptography, paramiko, python-engineio, python-socketio, flask-socketio, Pillow, requests, psutil, Flask-Session, SQLAlchemy, flask-sqlalchemy, greenlet, gevent, gevent-websocket, pyopenssl Found existing installation: Jinja2 2.9.6 Uninstalling Jinja2-2.9.6: Successfully uninstalled Jinja2-2.9.6 Found existing installation: six 1.10.0 Uninstalling six-1.10.0: Successfully uninstalled six-1.10.0 Found existing installation: Pillow 3.1.2 Uninstalling Pillow-3.1.2: Successfully uninstalled Pillow-3.1.2 Found existing installation: requests 2.18.4 Uninstalling requests-2.18.4: Successfully uninstalled requests-2.18.4 Successfully installed Flask-1.1.1 Flask-Session-0.3.1 Jinja2-2.10.3 Pillow-5.4.1 SQLAlchemy-1.3.11 Werkzeug-0.16.0 bcrypt-3.1.7 cffi-1.13.2 click-7.0 cryptography-2.8 enum34-1.1.6 flask-socketio-4.2.1 flask-sqlalchemy-2.4.1 gevent-1.4.0 gevent-websocket-0.10.1 greenlet-0.4.15 ipaddress-1.0.23 itsdangerous-1.1.0 paramiko-2.6.0 psutil-5.6.5 pycparser-2.19 pynacl-1.3.0 pyopenssl-19.1.0 python-engineio-3.10.0 python-socketio-4.3.1 requests-2.22.0 six-1.13.0 You are using pip version 9.0.1, however version 19.3.1 is available. You should consider upgrading via the ‘pip install –upgrade pip’ command. DEPRECATION: The default format will switch to columns in the future. You can use –format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning. You are using pip version 9.0.1, however version 19.3.1 is available. You should consider upgrading via the ‘pip install –upgrade pip’ command. Requirement already satisfied: psutil in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: chardet in /usr/local/lib/python2.7/dist-packages Collecting virtualenv Downloading https://pypi.tuna.tsinghua.edu.cn/packages/62/77/6a86ef945ad39aae34aed4cc1ae4a2f941b9870917a974ed7c5b6f137188/virtualenv-16.7.8-py2.py3-none-any.whl (3.4MB) 100% |████████████████████████████████| 3.4MB 63.1MB/s Requirement already satisfied: Flask in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: Flask-Session in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: Flask-SocketIO in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: flask-sqlalchemy in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: Pillow in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: gunicorn in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: gevent-websocket in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: paramiko in /usr/local/lib/python2.7/dist-packages Requirement already satisfied: itsdangerous>=0.24 in /usr/local/lib/python2.7/dist-packages (from Flask) Requirement already satisfied: Jinja2>=2.10.1 in /usr/local/lib/python2.7/dist-packages (from Flask) Requirement already satisfied: click>=5.1 in /usr/local/lib/python2.7/dist-packages (from Flask) Requirement already satisfied: Werkzeug>=0.15 in /usr/local/lib/python2.7/dist-packages (from Flask) Requirement already satisfied: python-socketio>=4.3.0 in /usr/local/lib/python2.7/dist-packages (from Flask-SocketIO) Requirement already satisfied: SQLAlchemy>=0.8.0 in /usr/local/lib/python2.7/dist-packages (from flask-sqlalchemy) Requirement already satisfied: gevent in /usr/local/lib/python2.7/dist-packages (from gevent-websocket) Requirement already satisfied: bcrypt>=3.1.3 in /usr/local/lib/python2.7/dist-packages (from paramiko) Requirement already satisfied: pynacl>=1.0.1 in /usr/local/lib/python2.7/dist-packages (from paramiko) Requirement already satisfied: cryptography>=2.5 in /usr/local/lib/python2.7/dist-packages (from paramiko) Requirement already satisfied: MarkupSafe>=0.23 in /usr/local/lib/python2.7/dist-packages (from Jinja2>=2.10.1->Flask) Requirement already satisfied: python-engineio>=3.9.0 in /usr/local/lib/python2.7/dist-packages (from python-socketio>=4.3.0->Flask-SocketIO) Requirement already satisfied: six>=1.9.0 in /usr/local/lib/python2.7/dist-packages (from python-socketio>=4.3.0->Flask-SocketIO) Requirement already satisfied: greenlet>=0.4.14; platform_python_implementation == “CPython” in /usr/local/lib/python2.7/dist-packages (from gevent->gevent-websocket) Requirement already satisfied: cffi>=1.1 in /usr/local/lib/python2.7/dist-packages (from bcrypt>=3.1.3->paramiko) Requirement already satisfied: enum34; python_version < “3” in /usr/local/lib/python2.7/dist-packages (from cryptography>=2.5->paramiko) Requirement already satisfied: ipaddress; python_version < “3” in /usr/local/lib/python2.7/dist-packages (from cryptography>=2.5->paramiko) Requirement already satisfied: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.1->bcrypt>=3.1.3->paramiko) Installing collected packages: virtualenv Successfully installed virtualenv-16.7.8 You are using pip version 9.0.1, however version 19.3.1 is available. You should consider upgrading via the ‘pip install –upgrade pip’ command. Collecting qiniu Downloading https://pypi.tuna.tsinghua.edu.cn/packages/0c/43/069ab7f8ebca63b17641622886cd3b806fa1e2f65fa8538e0ff0f303be2d/qiniu-7.2.6.tar.gz Collecting oss2 Downloading https://pypi.tuna.tsinghua.edu.cn/packages/11/93/b5041bd6472b0826de4326358c0ee61bb39d82714cfd47f500d4a23866c8/oss2-2.9.0.tar.gz (181kB) 100% |████████████████████████████████| 184kB 47.0MB/s Collecting upyun Downloading https://pypi.tuna.tsinghua.edu.cn/packages/16/54/c9758a773ee729b2e92f156c57dae08921e913b5cbf67251f08ed571e8ca/upyun-2.5.3-py2-none-any.whl Collecting cos-python-sdk-v5 Downloading https://pypi.tuna.tsinghua.edu.cn/packages/23/44/faa282d066f44e604a9ca42d41c5f25eee5ab36e7dc70f2e3f531736e0ee/cos_python_sdk_v5-1.7.5-py2-none-any.whl Requirement already satisfied: requests in /usr/local/lib/python2.7/dist-packages (from qiniu) Collecting crcmod>=1.7 (from oss2) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/6b/b0/e595ce2a2527e169c3bcd6c33d2473c1918e0b7f6826a043ca1245dd4e5b/crcmod-1.7.tar.gz (89kB) 100% |████████████████████████████████| 92kB 52.5MB/s Collecting pycryptodome>=3.4.7 (from oss2) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/09/4a/6aa4b0dbaf2a1836ca4d44af3d7388f79bdfee425db794d6ea531d405768/pycryptodome-3.9.4-cp27-cp27mu-manylinux1_x86_64.whl (9.7MB) 100% |████████████████████████████████| 9.7MB 65.5MB/s Collecting aliyun-python-sdk-kms>=2.4.1 (from oss2) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/d7/cd/a708ffe449138d8eb15a2018d31f131c4d38a5befc0668348620e1398e71/aliyun-python-sdk-kms-2.8.0.tar.gz Collecting aliyun-python-sdk-core>=2.6.2 (from oss2) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/2e/1e/efe2fbbda520c0c6e3b6f5e5b9def6d6fd2f57225290f7d1765db5a33592/aliyun-python-sdk-core-2.13.11.tar.gz (432kB) 100% |████████████████████████████████| 440kB 69.7MB/s Collecting dicttoxml (from cos-python-sdk-v5) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/74/36/534db111db9e7610a41641a1f6669a964aacaf51858f466de264cc8dcdd9/dicttoxml-1.7.4.tar.gz Requirement already satisfied: six in /usr/local/lib/python2.7/dist-packages (from cos-python-sdk-v5) Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python2.7/dist-packages (from requests->qiniu) Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests->qiniu) Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/dist-packages (from requests->qiniu) Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python2.7/dist-packages (from requests->qiniu) Collecting jmespath<1.0.0,>=0.9.3 (from aliyun-python-sdk-core>=2.6.2->oss2) Downloading https://pypi.tuna.tsinghua.edu.cn/packages/83/94/7179c3832a6d45b266ddb2aac329e101367fbdb11f425f13771d27f225bb/jmespath-0.9.4-py2.py3-none-any.whl Building wheels for collected packages: qiniu, oss2, crcmod, aliyun-python-sdk-kms, aliyun-python-sdk-core, dicttoxml Running setup.py bdist_wheel for qiniu … done Stored in directory: /root/.cache/pip/wheels/8f/b6/af/9ec9c37724398bdd7c47753d415bb5daaba04d28e2b2c2fb64 Running setup.py bdist_wheel for oss2 … done Stored in directory: /root/.cache/pip/wheels/fb/2b/ac/3733ba05feca6606d1e227b939d5cd760fb56f0b4b32d9bb89 Running setup.py bdist_wheel for crcmod … done Stored in directory: /root/.cache/pip/wheels/8b/8e/47/f5438529bcd5b472988aece2224377ba4772b2caf4d34dc151 Running setup.py bdist_wheel for aliyun-python-sdk-kms … done Stored in directory: /root/.cache/pip/wheels/b2/41/97/a44b04b7f277c55b610df0bdf479bb855c3b137cd4d96946f5 Running setup.py bdist_wheel for aliyun-python-sdk-core … done Stored in directory: /root/.cache/pip/wheels/fd/9c/ac/4b4a8b277ab791fdc75e13ccef7ab8c9139de927ae87abbe5a Running setup.py bdist_wheel for dicttoxml … done Stored in directory: /root/.cache/pip/wheels/f5/1e/8f/c59d17ab343058694b82fdc4dd0e8a8bec7dcd3cf65c399f36 Successfully built qiniu oss2 crcmod aliyun-python-sdk-kms aliyun-python-sdk-core dicttoxml Installing collected packages: qiniu, crcmod, pycryptodome, jmespath, aliyun-python-sdk-core, aliyun-python-sdk-kms, oss2, upyun, dicttoxml, cos-python-sdk-v5 Successfully installed aliyun-python-sdk-core-2.13.11 aliyun-python-sdk-kms-2.8.0 cos-python-sdk-v5-1.7.5 crcmod-1.7 dicttoxml-1.7.4 jmespath-0.9.4 oss2-2.9.0 pycryptodome-3.9.4 qiniu-7.2.6 upyun-2.5.3 You are using pip version 9.0.1, however version 19.3.1 is available. You should consider upgrading via the ‘pip install –upgrade pip’ command. Requirement already satisfied: gunicorn==19.0 in /usr/local/lib/python2.7/dist-packages You are using pip version 9.0.1, however version 19.3.1 is available. You should consider upgrading via the ‘pip install –upgrade pip’ command. Starting Bt-Panel… done Starting Bt-Tasks… done username: s4p6ofx4 Stopping Bt-Tasks… done Stopping Bt-Panel… done Starting Bt-Panel.. done Starting Bt-Tasks… done Reading package lists… Done Building dependency tree Reading state information… Done ufw is already the newest version (0.35-0ubuntu2). 0 upgraded, 0 newly installed, 0 to remove and 226 not upgraded. Rules updated Rules updated (v6) Rules updated Rules updated (v6) Command may disrupt existing ssh connections. Proceed with operation (y|n)? Firewall is active and enabled on system startup Default incoming policy changed to ‘deny’ (be sure to update your rules accordingly) Firewall reloaded ================================================================== Congratulations! Installed successfully! ================================================================== Bt-Panel: http://公网IP:端口/登录链接 username: 用户名 password: 密码 Warning: If you cannot access the panel, release the following port (8888|888|80|443|20|21) in the security group ================================================================== Time consumed: 2 Minute! root@iZ2ze24ocbpohl87u8q2pdZ:~#

请注意,安全组的端口一定要将面板放行(●°u°●)​ 」

5.安装后

最后就是,登录账号,进入面板,你会发现一个窗口

这里就按默认的来,安装LNMP,但一定要调高PHP的版本,不用担心兼容性问题,如果你想安装的软件真的不兼容高版本的PHP,那也别用了,估计早就是年久失修,bug出众了。

赞赏
别看了,没了。(*•̀ᴗ•́*)و ̑̑ 你是不是也看见很多博主都喜欢写一个什么禁止转载之类的话,反正我很讨厌那些东西╰(‵□′)╯,但开了博客才发现,原来写一个声明是多么的重要,所以,本文章由zd小达原创,未经允许,可以转载😊,但必须写明原文章的出处,本文链接https://zhangda.xyz/write/py/246/,仅发布于zd小达的博客和酷安(ღ˘⌣˘ღ)
首页      未分类      [Linux]纯净vps如何建站?戳这儿看看(*'▽'*)♪

zd小达

文章作者

发表评论

textsms
account_circle
email

zd小达's blos (๑>؂<๑)

[Linux]纯净vps如何建站?戳这儿看看(*'▽'*)♪
Linux——世界上为数不多的开源系统,它几乎遍布了我们的生活,而因为它的开源性,使得很多开发商都选择使用Linux vps来搭建网站,但。。。你想问了,Linux全是命令行,怎么建站呢?这就是…
扫描二维码继续阅读
2019-12-27